«前の日(12-19) 最新 次の日(12-21)» 追記

ポケットを空にして。

1985|10|
2004|01|02|03|04|05|06|07|08|09|10|11|12|
2005|01|02|03|04|05|06|07|08|09|10|11|12|
2006|01|02|03|04|05|06|07|08|09|10|11|12|
2007|01|02|03|04|05|06|07|08|09|10|11|12|
2008|01|02|03|04|05|06|07|08|09|10|11|12|
2009|01|02|03|04|05|06|07|08|09|10|11|12|
2010|01|02|03|04|05|06|07|08|09|10|11|12|
2011|01|02|03|04|05|06|07|08|09|10|11|12|
2012|01|02|03|04|05|06|07|08|09|10|11|12|
2013|01|02|03|04|05|06|07|08|09|10|11|12|
2014|01|02|03|04|05|06|07|08|09|10|11|12|
2100|01|

「人の心に残るというのが大事」と言う話。

何か連絡がある場合はメールでどうぞ(過去の日記へのツッコミは基本的にみていません)
プレゼントは随時受け付けております :-) ここ最近のツッコミ/トラックバックリスト。

  1. TJ (12-21)
  2. とおりすがり (12-20)


2004-12-20 この日を編集

現実逃避作業完了

ということで、2004年分の DSA はいったん訳し終わり。vulnerability は脆弱性だけは譲れないなー

渋谷で行商

行けなくなったチケットを譲渡。楽しんでくれると幸い。


2006-12-20 この日を編集

CNET 記事:リリースに遅れの次期Debian--開発者間の対立が影響か

Barth氏と、同じくリリースマネージャーのSteve Langasek氏は、
「Etch」(腐食)というコード名を持つDebianのバージョン4を
フルタイムで開発する見返りに各自最高6000ドルの資金を受け取り、
数カ月前から非難の的になっている。

腐食じゃないです、Etch A Sketch というおもちゃから取られています。誤訳ですね。

普段の進捗や機能概要などは一切取り上げないのに、こういう時だけ取り上げて訳を行うというのも恣意的ですね ;-)

んーどこみてんだろ

?なコメントが。フォント自体は入ってるけど Google Earth が認識してくれないという話なんですけどね。
slackware や Fedora でも出てるという話もあって解決してないし、アプリケーション側の問題だとは思われるけど。

本日のツッコミ(全2件) [ツッコミを入れる]

_ とおりすがり [CNETはsargeリリースの時も、リリースをミスったという内容の記事しか出しませんでしたね。]

_ TJ [皮肉ってわざと書いてるんだと思ってました > 腐食 マジで間違ってたのか(笑)]


2008-12-20 この日を編集

買い物予定

中島愛「天使になりたい」


2010-12-20 この日を編集

どんなことやったか@Bug#593082編

/usr/lib/ruby/1.9.1/xmldigest.rb をみると

require 'xml/dom/digest'

となっているが、digest.rbは存在していない。で、xmlparser-0.6.8からこのファイルをコピーして再度実行してみる。

henrich@hp115:$ ruby1.9.1 -e 'require "xmldigest"'
<internal:lib/rubygems/custom_require>:29:in `require': no such file to load -- md5 (LoadError)
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from /usr/lib/ruby/1.9.1/xml/dom/digest.rb:9:in `<top (required)>'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from /usr/lib/ruby/1.9.1/xmldigest.rb:1:in `<top (required)>'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from -e:1:in `<main>'

今度はmd5がない、とな。確かに

## -*- Ruby -*-
## DOMHASH test implementation
## 1999 by yoshidam
##
## Apr 20, 1999 Change for draft-hiroshi-dom-hash-01.txt
##
 
require 'xml/dom/core'
require 'md5'
require 'uconv'

と呼んでいる。md5 モジュールを探す。が、ruby1.9.1パッケージにはmd5.rbなんてものはない。???となってruby1.8でmd5.rbをみる。と先頭に

# just for compatibility; requiring "md5" is obsoleted
#
# $RoughId: md5.rb,v 1.4 2001/07/13 15:38:27 knu Exp $
# $Id: md5.rb 12007 2007-03-06 10:09:51Z knu $

と書いてある。obsoleted...じゃぁ何呼ぶのよ!

henrich@hp115:/usr/lib/ruby/1.9.1/digest$ ls
hmac.rb  sha2.rb

このあたりにもない…と思って中をみると、MD5が定義してあるっぽい。なので、digest.rbを書き換えて

require 'digest/md5'

とするとエラーが出なくなった。ふー。


2011-12-20 この日を編集

ipod touchをbansheeでマウントできたーよ

gvfs-fuse を入れたらすんなり解決してしまった… orz

追記: iOS5 だと認識して楽曲ファイル自体は転送できるが、iOS の方からは転送した楽曲が認識できないですな。


2012-12-20 この日を編集

雑作業

  • lintianのページを久々に確認して対応できそうなところを修正。standards-versionの更新だけの場合はローカルに変更しただけにしてアップロードはなし。